Projector Freezing on Boot

Seemingly out of no where, my projector just started to freeze during it’s booting sequence. It becomes totally unresponsive. The remote doesn’t seem to do anything, eye protection doesn’t kick in when passing my hand over the sensors, event the power button on the actual projector doesn’t seem to have any effect.

I use the projector at least once a week, and religiously check for firmware updates whenever I power the device on. So, unless something has been released between Oct. 17, 2021 and Oct. 22, 2021 I should have the latest and greatest.

I removed all HDMI connections to rule those out, and have tried the single troubleshooting step of unplugging and plugging it back in for like the 10th time.

Haven’t see any posts about this either, so wondering if anyone else has ever encountered something similar.

Hi @DarkCura We regret to hear that your remote control is not responding anymore. You can repair the remote by changing the battery and simply pressing and holding the return and menu buttons on your remote for 10 seconds while being within 2 feet from the projector. This is a guaranteed way of getting the remote reconnected to the projector. If you find that this did not work we can send another remote to your house ASAP.

In the meantime, you can download our VAVA Projector app found in the Apple/Playstore which has a fully functioning remote for you to utilize. Alternatively, you can also plug in any USB mouse to the back of the projector as another means to control your media.

If issue persists please email us at so we can further assist you.

Yeah… if the remote were the problem I would have changed batteries. The remote is not the issue. The projector itself becomes visually locked on whatever frame was being displayed about 5 -15 seconds after it has booted. It does not accept input from the remote or the app. The device becomes so frozen I could stare directly in to the laser indefinitely because because the detection does not kick in because the frame being displayed does not change.

Hi @DarkCura We regret to hear you are having issues with your VAVA 4K UST Projector. Would you be so kind to try the following steps to see if it solves the issue?

Make sure it is not overheating and there’s enough space for proper air ventilation. It needs at least 30cm of space from the sides, for proper airflow. Try a power cycle of the unit press the power button for 5-10 sec, unplug from the wall outlet, restart the unit, check fan noise, factory reset and check what is the firmware version installed.

If the issue is still not fixed, kindly take a video of it and send it to Thank you!