ARC Suddenly Stopped. Cannot Connect agein

I have been using the 4k projector with a vizio soundbar through ARC for about 4 months. It is also utilizing an amazon firecube as the main media source. Today, the 4k abruptly lost sound and CEC function. I could not get the sound bar to reconnect. I tried a factory reset, but CEC and ARC still both are not working. Any suggestions?

Hi @suoviatco. Since the projector supports Dolby Digital as its sound source please try to check the settings on your Amazon Fire TV Cube by going to Settings > Display & Sounds > Audio > Dolby Digital Output and then turn Dolby Digital Plus OFF. On the projector make sure sound output is set to HDMI ARC and try to toggle between RAW and PCM as for the soundbar if there’s an option to turn off Dolby Atmos then please try to turn it off.

If you have any further questions or concerns please contact us at Thank you!


I have been using the 4k projector with my soundbar and firecube for about 4 months. Last week while watching some basketball, the sound suddenly cut out. At that point, the ARC stopped working all together as well as the CEC to both the firecube and the soundbar. I tried the following:

  1. Unplug and then replug the projector power.

  2. Unplug and then replug the firecube and soundbar power

  3. Unplug and then reconnect all hdmi connections into the projector

  4. factory reset of the projector and reconnect everything

None of these attempts have worked on restoring ARC or CEC. At this point, I am back to using the projector speakers as I can no longer connect through HDMI to the soundbar.

I actually think it may be the CEC/ARC controller that shorted out? It was just a sudden cut out in sound and connection and it can no longer connect.

Hello @suoviatco Thank you for letting us know what you are going through with the ARC/CEC issue and thank you for applying the recommended troubleshooting steps. To help you further kindly reach out to our team at