VAVA Dashcam Wifi all messed up

I have a vava dashcam that has been working great. Up until a few days ago. Now the wifi SSID shows up with random characters and the thing sits here and chirps nonstop like its warning me about pot holes or rumble strips.
We’ve dug through everything that we can find to try and locate your firmware for download so we can flash the camera back to a functioning state. However every link that has been documented in the manual and support guides no longer functions. Can anyone please provide me with a download link?

Yes I know it should update via the app but if I can’t get my phone to connect to the camera via wifi its going to have a really hard time trying to update via the app.

1 Like

I’m having the same exact issue. I’ve tried the reset button I’ve tried a new memory car for it.
I emailed support but idk when they will get back to me with Corona going on.

After talking with support I was able to fix this. Take the memory out of the camera, use the reset button and connect it to the app first. Then use the app to update and everything should be good.
Do not put the memory card in until your connected to the app and it’s wifi