VAVA chroma: Disney Plus app Audio issue

Hi, I am facing issue with Audio on Vava chroma while casting to Chromecast from Disney Plus app. I faced same problem with Prime video app but this app had setting to downgrade audio quality which fixed the issue. I dont see audio downgrade option on Disney Plus app. Its very annoying to hear audio breaking every few seconds. Please let me know how to fix this.
Please note the video quality when streaming from locally installed apps on projector is really bad so I had to cast it from other devices.

Hi, @vish22 This issue has been raised with our development team. How about if you used a 3rd party streaming device does Disney Plus app audio work?

Please email our to forward the error msg or short video of the issue. Thank you!

Hi, I am mentioning below 2 configurations, first one is working fine, second one has audio glitch issue.

  1. disney plus casted from mobile phone + hdmi1 port chromecast device + samsung tv
  2. disney plus casted from mobile phone + hdmi1 or hdmi2 port chromecast device + Vava Chroma

Disney plus installed on chroma has no audio issue but video quality in not good, so I tried casting from external device.


1 Like

Hi @vish22 We would like to verify if you’re having the same issue while using external speakers? Also, If you are using a 3rd party streaming device try to change the audio mode to either stereo, Dolby Digital, or turn off Dolby Digital Plus/Dolby Atmos.

Hi Vava,

I have the same issue. I used the Chromecast with Google TV to play videos on Disney+ and Netflix, but chroma had no sound. Chromecast with Google TV works perfect with my Sharp TV.

I also tried Apple TV. Sometimes chroma didn’t have sound for Disney+ videos and I needed to close the video and play it again to make the sound work on chroma.

Please make sure this issue is tracked.


Hi @jasonlingo We appreciate your feedback. We will look into it immediately. As per our development team, the next release for the next firmware update will be this month.

Thanks, VAVA team!

Another case is that if I use SurfShark VPN in Chromecast with Google TV, the Disney+ videos will have no sound. I used the same setting on my Sharp TV and it works well. Can you also report this issue?


Hi, @jasonlingo Thank you for your feedback. We will look into this. We need to check first if the SurfShark VPN is compatible with Chroma. We will get back to you as soon as we heard back from the development team. Thank you for the support!

Hi @jasonlingo We would like to verify how did you use the VPN on the projector, is it via computer, or are you using VPN as your internet access? Can you try to do a power cycle in the unit? Unplug the unit from a power outlet for about 5 mins, then re-plug and test it, factory reset and check what is the firmware version installed.

Please note if you are using a 3rd party streaming device try to change the audio mode to either stereo, Dolby Digital, or turn off Dolby Digital Plus/Dolby Atmos.

If the issue persists, kindly email

Hi Vava Team,

I tested it again and found it might not be related to the VPN. The original audio issue is not solved yet. One interesting case I found is that when I play the “Avengers: End Game” movie, it has no sound if I choose English/Spanish…etc., but it will have sound if I choose “English [Audio Description]” and other language with audio description. Please see my recording of the test: Google Drive.

I used Chromecast with Google TV (product link) and it works fine with my Sharp TV, but has the audio issue with VAVA Chroma. This issue might also happen in other apps like Netflix as some videos in Netflix don’t have audio either.

Please investigate the issue and let me know if you need more information.

Hi, @jasonlingo Have you tried changing the audio mode? Are you using a 3rd party speakers? If so could you try using the audio-only on the projector? Let us know if it works. Also kindly email our VAVA Chroma team at

I tried all the audio modes, but no one worked. I used the built-in speaker. This only happens when I use VPN in the Chromecast with Google TV. However, it works perfect with my Sharp TV even with VPN.

Don’t know what happened. Please let me know if you need more information and please help with the debugging.


I have these same issues with netflix om Dolby stereo, but here you can. choose original stereo where audio then works. For Disney+, and HBO you cannot choose a lesser sound quality and here sound doesnt work. Clearly this is an issue with the Chroma, so please inform when we can expect it to be solved.

1 Like

Hi, @jasonlingo, You may try this one this works with other customers.

Go thru the audio settings from the movie off your source. Whatever you’re using to cast your video. Somehow it doesn’t work when you’re playing Dolby so you have to switch off to stereo.
For Chroma - using Arc, make sure CEC was on and turn the chroma audio set to RAW.

For the newer Chromecast TV stick.
Head into “Advanced sound settings” switch to Manual format selection and turn off Dolby Digital Plus