USB C Hub stopped working suddenly within warranty

Ordered from Amazon on February 22, 2021 (1 item)

VAVA USB C Hub, 8-in-1 USB C Adapter with 4K HDMI, 1Gbps RJ45 Ethernet Port, USB 3.0, SD/TF Card Reader, 100W PD Charging Port for MacBook/Pro/Air and

It worked fine and then stopped completely on July 5, 2021. I want a replacement ASAP!

Hi @kvetcher We are sorry for the issue that you have with our device. Have you tried restarting your device while all the inputs are plugged in? For us to further help you resolve this, kindly reach out to our team at support@vava.com.

Yes I have. Doesn’t fix it.

Jonathan Cohen FAIA
Poplar Design Advisors

Hello @kvetcher We appreciate you applying the recommended troubleshooting. Our team at support@vava.com can help you with a warranty claim.

Are you going to honor your warranty or not? I want a replacement ASAP. I can’t afford to have a unit that fails randomly.

Jonathan Cohen FAIA
Poplar Design Advisors

Hello @kvetcher we are sorry for the confusion, we do not provide RMA on this channel. You need to reach out to our team at the email support@vava.com for that request.

I hope this helps clear the misunderstanding.

i am having the same issue with this hub after 4 months. Hope it does not need firmware update or it expires after 4 months since @kvetcher also has the same problem after around 4 months.

Hi @spa Thank you so much for notifying us about the issue. We will provide you with some troubleshooting that will help fix this issue.

Hub troubleshooting:

  1. Unplug & Replug the hub
  2. Reboot your PC/Laptop/Ipad/Phone (whichever device your using)
  3. Try to connect it to a different computer/laptop.

Thank you! Have a great day.

I have the same issue on the second one. It worked once with the OFIYAA tri screen then quit working. spent hours with chat on the first one that went bad… was informed to send it back to the original retailer. Then bougbt one directly got it today plugged it in… same problem.

Called customer support persons were not knowledgeable at all.

Hi @jjones734 We regret to hear that you’re experiencing the same issue. This is something we don’t want our customers to experience. We will look into it immediately. Since this was a new USB C-HUB have you tried testing it on other PC’s/Laptop just to check if it’s doing the same error.