Update causes crash

Has anyone else received update notifications?

I currently run V1.91 I tried to update. Just eventually ends up with an Android image with “error” is this just a corrupted file or my vava?


I had the same issue, awaiting for a post in these forums to help? Please keep us posted

Same here. Tried to reboot 3 times but crash during installation. Back to older version.

Had the same problem. After a restart the install went through.

Same problem for me, if I get any fix ,I will contact you.

Same problem trying to do the update

Same issue here :frowning: - have sent an email to support. Let’s see if there is an fix or workaround for this issue.

Same problem, unable to install the update

Received email from support on 12/22/2020, that a new firmware update to follow v2.10, I will let you know when this available.
They did respond pretty fast, sorry I’m just posting now, due to holiday.

The firmware V2.10 was released on 23. December, at least that is the date i installed it.

The reply you postet said that v2.10 will follow the faulty v2.0 .

So i guess you made a mistake claiming that “a new firmware update to follow V2.10”?

Hi Quinn

Thanks for the information, I received the email on 12/22, I wasn’t aware of the release on 12/23. I will try and reinstall. Greatly appreciate the information.

Thank you

My projector took the update to 2.10, it did at first install 2.01 and error, projector reset and the new file was downloaded and installed without any problems. I’m currently running the 2.10 without any issues

The same issue. Nothing seems to fix it. Driving me insane. Also my Wifi now isn’t being recognized after resetting everything to default. What a clusterf*ck.

We regret to hear you are having issues with your WiFi connection after
I’m sorry to hear you are having trouble. Would you be so kind try the following steps:

  1. Try to do another factory reset.
  2. Once the projector is reset, please make sure that the projector has the latest firmware.
    This can be done by going to Settings>General>Update version.
    If the issue is still not fixed, kindly take a photo/video of it and send it to support@vava.com. Thank you

Same. New VAVA > Update Firmware > CRASH! > Reboot > Finishes.

Love this projector!


@sacolton We appreciate your support for the VAVA 4k UST Projector and appreciate your feedback. We are glad that after the reboot the firmware update finished up and your projector is running on the latest version.