Roku Ultra + VAVA 4k. HDR Content?


I recently got the VAVA 4k projector, and i connected my roku ultra. When i go to displays and do Auto Detect, it only sets the display to 1080p. If i go and select 4k HDR TV, then it does say that its setting res to do 4k @60 fps and youtube etc does run at 4k, however Netflix, that requires 4k @ 60 fps still only does 1080p ( all shows are in HD, instead of Dolby Vision ). I have tried another high speed hdmi cable that claims to support 8k @ 60 fps too but i get the same result. Not sure what to do at this point since i know Roku ultra and vava 4k are both capable of 4k HDR content.

Hello, @deepdmistry Thank you for notifying us. We will look into this immediately. Hope this helps. The cable required to stream 4K videos is HDMI 2.0 and HDCP 2.2. In order to enable 4K please turn on HDMI 2.0 function on the projector. Also, If you are using a 3rd party streaming device try to change the audio mode to either stereo, Dolby Digital, or turn off Dolby Digital Plus/Dolby Atmos. If the issue persists kindly reach our to further assist you.

What do you mean by please turn on HDMI 2.0 function on the projector? . How do i do that ? I thought 4k would be enabled by default on the projector. Is that not the case ?

Hi, @deepdmistry Yes, that is not the case. To activate the HDMI 2.0 on your projector. Kindly watch this link VAVA 4K UST Projector Tutorial #5: How to set up HDMI 2.0 - YouTube or simply select the signal source, then press and hold the menu button then select HDMI 2.0 activate it.