Not getting 4K with Fire TV Stick 4K?

Probably a dumb-sounding question, but how do I know if I’m getting 4K? I have an Amazon Fire TV Stick 4K. When I use the Netflix app, every show and movie shows only the “HD” badge. I’ve pored through all the settings for both the Fire TV Stick and Netflix itself.

In Movies Anywhere, I have 4K content, but the app says “this device does not support 4K viewing.”

I tried connecting a Roku… went into the settings and had to force-select 4K 60Hz HDR. That seemed to work; I was able to see Netflix content in 4K.

But where’s the disconnect here? Why does all content seem to be “downshifting” to 1080p?

Hi @Justrick Our VAVA 4k projector will always try to pixel shift the output image to 4k. This being mentioned, you can still try to go to your Fire TV stick’s settings and try to follow the steps below.
Go to Settings > Display & Sounds > Display. Open the Video Resolution section. Set your video resolution to Auto. A notification displays if HDCP 2.2 is not detected for your Fire TV’s HDMI connection.

If the issue persists, kindly reach out to to further troubleshoot.

Thanks for the response. The Fire TV Stick is definitely set to Auto. There’s no notification saying HDCP 2.2 not detected.

If I go into an app like Netflix, none of the content shows the “UHD” or “4K” badge… I only ever see “HD.”

In the Movies Anywhere app, I have movies that are definitely 4K… but I see the message, “4K not supported on this device.”

So I don’t know if the issue is with the Fire TV Stick or the projector. Unfortunately, the projector offers no way to see what resolution is selected or currently displayed.

Hello Justrik.

Thank you for the message.

It seems that your HDMI 2.0 feature is not enabled to allow you to receive 4k, you can turn it on by going into our extended menu.
Select the HDMI channel from your Home Screen that has the Firestick 4k connected and click it to start viewing. Now, press and home the menu button on your VAVA remote for 2 seconds.
An extended menu should appear with various options. Scroll down until you see HDMI 2.0 and enable it to start viewing the content in 4k.
There are a few options available on the extended menu, feel free to look around and let us know if you have any questions.

Best regards,

Thank you! Had no idea there was an extended menu. That solved the problem.