Need Help! Nothing but issues with 1.9.1

I need help. I’ve been going crazy trying to fix my firmware issues. Started out of nowhere with the prompt to upgrade firmware from 1.9.1 to latest. Never had any issues before. After restarting (post upgrade) it would constantly fail and throw an Android error with the android icon. Nothing worked to fix this, had to pull plug for restart, tried several times, not pressing Okay, tried the fix .apk off the website etc. Tried resetting the software to stock… the latest B.S I’m dealing with is now an inability to connect to Wifi! It either stops looking and finding networks or it simply won’t take my damn Password. It’s driving me nuts. I don’t have a cable long enough for ethernet and I’m out of ideas.

Incredibly frustrating. Help appreciated!

It is not good to hear that you are having this issue. We do apologize. Please contact our support team via email ( so you can be further assisted. Kindly include a short video of the issue and your order number in the email you will send. Thank you!