Just got my Vava

Just got it having a few issues:

cant connect to internet, tried known good cable in and known good wi fi both give the error:

‘connection anomaly’

im on version 1.91

thinking I should try and download the latest update and install via USB and then try to get it to connect to internet. But cant find the download link

Any idea what this error is? I can go to the play store and install apps so I know it is able to connect to the internet - just gives the error. But I can’t update.

Also I would like to do a factory reset and install the firmware but where is the link to download?

firmware 1.91 is the newest firmware out.

Thanks Quinn. So, I guess my VAVA is connecting to the internet - just showing the odd connection error…?

Is this site actively monitored by VAVA?

Don´t know if this site is monitored by VAVA, but it doesn´t look like it.At least i have never seen a post from vavateam.

My Vava doesn´t have connection problems. So maybe yours is faulty?

I also have this issue. I’m on V1.91 and the network tests always fail.

I ordered mine through vava.com but I bought the black one instead of the usual white colored projector if that makes a difference.

@krypto the firmware doesn’t appear to be something you can just grab off internet, I can’t find it either.

You can download an old firmware directly from the vava support website. Don´t know why they haven´t updatet it yet.

I did find the firmware - it is not where every other tech company has put theres for the last 20 years - in Support area, It is on the main product page and the latest isnt on there 1.91.

FWIW - My Vava shows the connection error - but appears to work correctly.

Oh I see it now, I’m not sure how I missed that but thanks.

Is not only yours, mine does too, even with the error I can be able and instal the update, hardwired, update time settings and connect to wifi, restart the mdm and router

I just got my Black VAVA with version 1.9.1, and I see the same error, but I can still connect to the internet. It must be a bug.

This among several other issues (fan noise - no harmony support ) are the reasons I will be returning my Vava. Kinda of a shame because it’s close to being a decent product but not close enough.

Got an Optoma P1 for about the same price. No fan noise IR remote and real support.

We apologize for the late response and if you had issues with your VAVA 4k projector. Would you be so kind to try the following steps to see if it solves the issue.

  1. Try to do a factory reset.
  2. Check if the firmware version installed is updated to v2.10.

For more inquiries or feedback, you may reach out to support@vava.com. Thank you