CEC doesn’t shut off projector

Can you guys fix the CEC “off” command. Doesn’t work with Roku, Xbox etc. This is ridiculous. Or can you tell me how to issue a command over wifi since the phone app somehow does it. Was excited to update to 2.20 hoping to see this fixed. Still broken.

1 Like

Hi, @Vava1 Thank you for notifying us about the issue. Actually, this is not broken. This is a limitation with the projector. As a workaround, some customers are able to use a power relay to switch off the unit and it works fine. Please note there is still some risk mainly result of poor wiring.

Also, a relay can be considered as unplugging plugging the electronic device from the power source.

Will this be fixed in a future update? The old projector did it just fine. Initially it acted the same and didnt close the screen but one of the updates worked.
What does this relay look like as a work around?

Hi @keithswick We are also, looking forward to future upgrades For the power relay we are not familiar with it and we don’t recommend it as it might risk the unit due to some poor wirings. But some of the customers have mentioned about it. If you wanna learn more about power relay we suggest you ask for more information from a local technician.

Team VAVA that is unacceptable. CEC control allows for power on of the device. The projector is physically capable of turning off as you can turn it off via the app over a wifi command. You simply have not incorporated it. Apple TV for example can issue a turn off command, why can’t my roku or my Xbox issue the command. They can power off all of my other TVs over CEC. Please fix this.

I’ve been posting about this for over a year now with no fix. They have moved on to their new projector so I dont think we will ever get any support.

You’re right. Which is the reason I will never go with a no name brand again. I’ve steered 5-6 friends away from this projector due to the complete lack of customer support. Just constant illusions of a possible fix as they “talk to their engineers”. Crock of shit.

Side note. If you’re into home automation I found there is a way to use an esp32 to simulate a keyboard which can send a power off command. Haven’t figured it out yet but there’s a guy who has. Ridiculous I have to teach myself basic coding to get BASIC functionality.

1 Like

Yes! Could you point me to a link for that or any other info (found a Reddit conversation, but few details)? I have a bunch of esp32 and esp8266 ready to go for something like this and run an extensive Home Assistant automation setup (with ESPHome). I’d also love to help if possible. First blip of hope I’ve seen on this forum!!

1 Like

I’m in HASS right now trying to configure my roborock lol. Let’s figure this out together!!!

AppleTV worked on the original projector to turn on/off but the new one only gets the on command right.

also, when turning off projector via vava remote it doesnt send off to the usb for the screen. Maybe overlooked??? Used to work on OG projector…

Check out the reddit link. Took me a few hours yesterday to get it all to work but now my xbox shutting off will trigger an HA automation to send a command to the esp32 and shut of the projector. On the reddit i posted detailed instructions on how to get it all to work.

2 Likes

Hi, @Vava1 We appreciate your help in sharing feedback. This will surely help other customers that have a related concern. Have an amazing day to you!